[Gluster-users] Enomaly users, please read -

Craig Carl craig at gluster.com
Fri Jun 24 20:57:24 UTC 2011

All -

Gluster has identified a serious issue that affects anyone hosting VM 
images for the Enomaly Elastic Cloud Platform with Gluster. This issue 
is limited to Gluster versions =<3.1.4.  We strongly encourage anyone 
using Enomaly and Gluster to upgrade to Gluster version 3.1.5 or higher.

What causes the failure -

Use a distribute-replicate volume.
Mount using either NFS or the GlusterFS.
Fail one of replica nodes.
     ** Production is unaffected at this point.
Restart the failed node.
    ** All the virtual machines fail.
    ** The ecpagent service on each hypervisor will constantly restart.

Root cause -

Enomaly uses a locking mechanism in addition to and above the standard 
POSIX locking to make sure that a VM never starts on two servers at the 
same time. When a Enomaly sever starts a VM it writes a file 
(<randomstuff.tmp> to the directory. The combination of self-heal and a 
race between the ecpagents on the hypervisors results in the VMs failing 
to start. No data is lost or damaged.

Again, this issue is specific to Enomaly. Enomaly users should 
immediatly upgrade to a version of Gluster =>3.1.5.



Craig Carl
Senior Systems Engineer | Gluster
408-829-9953 <callto:+1408-829-9953>| San Francisco, CA
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20110624/c77ce027/attachment.html>

More information about the Gluster-users mailing list