[Gluster-users] Copying data failed on distributed replicated volume (ver. 3.1.3)

Ethan Nguyen tmsndte at nus.edu.sg
Thu Sep 1 21:58:23 PDT 2011


Hi,

I am trying to backup data from a distributed replicated volume.

The volume was built from 6 units of 2 TB hard disks:

gluster> volume info

Volume Name: 6TB-Vol
Type: Distributed-Replicate
Status: Started
Number of Bricks: 3 x 2 = 6
Transport-type: tcp
Bricks:
Brick1: c107:/exp0
Brick2: c108:/exp0
Brick3: c109:/exp0
Brick4: c110:/exp0
Brick5: c111:/exp0
Brick6: c112:/exp0
Options Reconfigured:
cluster.self-heal-window-size: 1024
cluster.data-self-heal-algorithm: full
diagnostics.brick-log-level: DEBUG
diagnostics.client-log-level: DEBUG

c107: /dev/sdd1     ext2    1.8T  1.2T  566G  68% /exp0
c108: /dev/sdd1     ext2    1.8T  1.2T  566G  68% /exp0
c109: /dev/sdd1     ext2    1.8T  1.2T  533G  70% /exp0
c110: /dev/sdd1     ext2    1.8T  1.2T  533G  70% /exp0
c111: /dev/sdd1     ext2    1.8T  1.3T  495G  72% /exp0
c112: /dev/sdd1     ext2    1.8T  1.3T  495G  72% /exp0

When I backup the data to another storage, cp command hangs with "Invalid argument" errors.

I also tried this command: find <mount-point> -print0 | xargs --null stat >/dev/null and it didnt help.

I really need to get the data from  this volume. Please help!!!

Regards,
Ethan

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://gluster.org/pipermail/gluster-users/attachments/20110902/9c4579bf/attachment.htm>


More information about the Gluster-users mailing list